CVE-2023-50378
Medium
Description
Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Apache Ambari
PublishedMar 1, 2024
First seenMar 1, 2024
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache ambari2.7.8 or later
- org.apache.ambari:ambari2.7.8 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ambari | 2.7.0 ≤ v < 2.7.8 | 2.7.8 |
| org.apache.ambari:ambariMaven | v < 2.7.8 | 2.7.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.