CVE-2023-50380
Description
XML External Entity injection in apache ambari versions <= 2.7.7, Users are recommended to upgrade to version 2.7.8, which fixes this issue. More Details: Oozie Workflow Scheduler had a vulnerability that allowed for root-level file reading and privilege escalation from low-privilege users. The vulnerability was caused through lack of proper user input validation. This vulnerability is known as an XML External Entity (XXE) injection attack. Attackers can exploit XXE vulnerabilities to read arbitrary files on the server, including sensitive system files. In theory, it might be possible to use this to escalate privileges.
How to fix
- apache ambari2.7.8 or later
- org.apache.ambari.contrib.views:wfmanager2.7.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ambari | 2.7.0 ≤ v < 2.7.8 | 2.7.8 |
| org.apache.ambari.contrib.views:wfmanagerMaven | 2.7.0 ≤ v < 2.7.8 | 2.7.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.