CVE-2023-50709

Medium

Description

Cube is a semantic layer for building data applications. Prior to version 0.34.34, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. The issue has been patched in `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption. There are currently no workaround for older versions, and the recommendation is to upgrade.

SeverityMedium
CVSS6.5
Exploit probability—
ProductCube.js
PublishedDec 13, 2023
First seenDec 13, 2023

How to fix

Update
  • cube cube.js0.34.34 or later
  • @cubejs-backend/api-gateway0.34.34 or later

Affected products

ProductAffected versionsFixed in
cube cube.jsv < 0.34.340.34.34
@cubejs-backend/api-gatewaynpmv < 0.34.340.34.34

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.