CVE-2023-50783

Medium

Description

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Airflow
PublishedDec 21, 2023
First seenDec 21, 2023

How to fix

Update
  • apache airflow2.8.0 or later
  • apache-airflow2.8.0 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.8.02.8.0
apache-airflowPyPIv < 2.8.02.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.