CVE-2023-50927

High

Description

Contiki-NG is an open-source, cross-platform operating system for Next-Generation IoT devices. An attacker can trigger out-of-bounds reads in the RPL-Lite implementation of the RPL protocol in the Contiki-NG operating system. This vulnerability is caused by insufficient control of the lengths for DIO and DAO messages, in particular when they contain RPL sub-option headers. The problem has been patched in Contiki-NG 4.9. Users are advised to upgrade. Users unable to upgrade should manually apply the code changes in PR #2484.

SeverityHigh
CVSS8.6
Exploit probability—
ProductContiki-ng
PublishedFeb 14, 2024
First seenFeb 14, 2024

How to fix

Update
  • contiki-ng contiki-ng4.9 or later

Affected products

ProductAffected versionsFixed in
contiki-ng contiki-ngv < 4.94.9

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.