CVE-2023-50943

High

Description

Apache Airflow, versions before 2.8.1, have a vulnerability that allows a potential attacker to poison the XCom data by bypassing the protection of "enable_xcom_pickling=False" configuration setting resulting in poisoned data after XCom deserialization. This vulnerability is considered low since it requires a DAG author to exploit it. Users are recommended to upgrade to version 2.8.1 or later, which fixes this issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Airflow
PublishedJan 24, 2024
First seenJan 24, 2024

How to fix

Update
  • apache airflow2.8.1 or later
  • apache-airflow2.8.1rc1, 2.8.1 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.8.12.8.1
apache-airflowPyPIv < 2.8.1rc1, v < 2.8.12.8.1rc1, 2.8.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.