CVE-2023-5109

Medium

Description

The WP Mailto Links – Protect Email Addresses plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'wpml_mailto' shortcode in versions up to, and including, 3.1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 3.1.3 and fully patched in version 3.1.4.

SeverityMedium
CVSS6.4
Exploit probability—
ProductIronikus Wp Mailto Links
PublishedOct 20, 2023
First seenOct 20, 2023

How to fix

Update
  • ironikus wp_mailto_links3.1.4 or later

Affected products

ProductAffected versionsFixed in
ironikus wp_mailto_linksv < 3.1.43.1.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-5109 · Ironikus Wp Mailto Links · Dark Radar