CVE-2023-51379
Description
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed issue comments to be updated with an improperly scoped token. This vulnerability did not allow unauthorized access to any repository content as it also required contents:write and issues:read permissions. This vulnerability affected all versions of GitHub Enterprise Server since 3.7 and was fixed in version 3.17.19, 3.8.12, 3.9.7, 3.10.4, and 3.11.1.
How to fix
- github enterprise_server3.7.19, 3.8.12, 3.9.7, 3.10.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.7.0 ≤ v < 3.7.19, 3.8.0 ≤ v < 3.8.12, 3.9.0 ≤ v < 3.9.7, 3.10.0 ≤ v < 3.10.4, 3.11.0 | 3.7.19, 3.8.12, 3.9.7, 3.10.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.