CVE-2023-51380

Low

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed issue comments to be read with an improperly scoped token. This vulnerability affected all versions of GitHub Enterprise Server since 3.7 and was fixed in version 3.7.19, 3.8.12, 3.9.7, 3.10.4, and 3.11.1.

SeverityLow
CVSS2.7
Exploit probability—
ProductGithub Enterprise Server
PublishedDec 21, 2023
First seenDec 21, 2023

How to fix

Update
  • github enterprise_server3.7.19, 3.8.12, 3.9.7, 3.10.4 or later

Affected products

ProductAffected versionsFixed in
github enterprise_server3.7.0 ≤ v < 3.7.19, 3.8.0 ≤ v < 3.8.12, 3.9.0 ≤ v < 3.9.7, 3.10.0 ≤ v < 3.10.4, 3.11.03.7.19, 3.8.12, 3.9.7, 3.10.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.