CVE-2023-51437

High

Description

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

SeverityHigh
CVSS7.4
Exploit probability—
ProductApache Pulsar
PublishedFeb 7, 2024
First seenFeb 7, 2024
Weakness typeCWE-203CWE-203

How to fix

Update
  • apache pulsar2.11.3, 3.0.2 or later
  • org.apache.pulsar:pulsar-broker-auth-sasl2.11.3, 3.0.2, 3.1.1 or later

Affected products

ProductAffected versionsFixed in
apache pulsarv ≤ 2.10.5, 2.11.0 ≤ v < 2.11.3, 3.0.0 ≤ v < 3.0.2, 3.1.02.11.3, 3.0.2
org.apache.pulsar:pulsar-broker-auth-saslMavenv < 2.11.3, 3.0.0 ≤ v < 3.0.2, 3.1.0 ≤ v < 3.1.12.11.3, 3.0.2, 3.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.