CVE-2023-51770

High

Description

Arbitrary File Read Vulnerability in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.1. We recommend users to upgrade Apache DolphinScheduler to version 3.2.1, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Dolphinscheduler
PublishedFeb 20, 2024
First seenFeb 20, 2024

How to fix

Update
  • apache dolphinscheduler3.2.1 or later
  • org.apache.dolphinscheduler:dolphinscheduler3.2.1 or later

Affected products

ProductAffected versionsFixed in
apache dolphinscheduler1.2.0 ≤ v < 3.2.13.2.1
org.apache.dolphinscheduler:dolphinschedulerMavenv < 3.2.13.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.