CVE-2023-51785
High
Description
Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.7.0 through 1.9.0, the attackers can make a arbitrary file read attack using mysql driver. Users are advised to upgrade to Apache InLong's 1.10.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/9331
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Inlong
PublishedJan 3, 2024
First seenJan 3, 2024
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- org.apache.inlong:manager-pojo1.10.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache inlong | 1.7.0 ≤ v ≤ 1.9.0 | — |
| org.apache.inlong:manager-pojoMaven | 1.5.0 ≤ v < 1.10.0 | 1.10.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.