CVE-2023-6804

Medium

Description

Improper privilege management allowed arbitrary workflows to be committed and run using an improperly scoped PAT. To exploit this, a workflow must have already existed in the target repo. This vulnerability affected all versions of GitHub Enterprise Server since 3.8 and was fixed in version 3.8.12, 3.9.7, 3.10.4, and 3.11.1.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGithub Enterprise Server
PublishedDec 21, 2023
First seenDec 21, 2023

How to fix

Update
  • github enterprise_server3.8.12, 3.9.7, 3.10.4 or later

Affected products

ProductAffected versionsFixed in
github enterprise_server3.8.0 ≤ v < 3.8.12, 3.9.0 ≤ v < 3.9.7, 3.10.0 ≤ v < 3.10.4, 3.11.03.8.12, 3.9.7, 3.10.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.