CVE-2023-7158

High

Description

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

SeverityHigh
CVSS7.3
Exploit probability—
ProductMicropython
PublishedDec 29, 2023
First seenDec 29, 2023
Weakness typeCWE-122CWE-122

How to fix

Affected products

ProductAffected versionsFixed in
micropython micropythonv < 1.22.01.22.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.