CVE-2024-0394

High

Description

Rapid7 Minerva Armor versions below 4.5.5 suffer from a privilege escalation vulnerability whereby an authenticated attacker can elevate privileges and execute arbitrary code with SYSTEM privilege.  The vulnerability is caused by the product's implementation of OpenSSL's`OPENSSLDIR` parameter where it is set to a path accessible to low-privileged users.  The vulnerability has been remediated and fixed in version 4.5.5. 

SeverityHigh
CVSS7.8
Exploit probability—
ProductMinerva
PublishedApr 3, 2024
First seenApr 3, 2024

How to fix

Update
  • Rapid7 Minerva4.5.5 or later

Affected products

ProductAffected versionsFixed in
Rapid7 Minervav < 4.5.54.5.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.