CVE-2024-0507
Medium
Description
An attacker with access to a Management Console user account with the editor role could escalate privileges through a command injection vulnerability in the Management Console. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in versions 3.11.3, 3.10.5, 3.9.8, and 3.8.13 This vulnerability was reported via the GitHub Bug Bounty program.
SeverityMedium
CVSS6.5
Exploit probability—
ProductGithub Enterprise Server
PublishedJan 16, 2024
First seenJan 16, 2024
Weakness typeCWE-20Improper input validation
How to fix
Update
- github enterprise_server3.8.13, 3.9.8, 3.10.5, 3.11.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.8.13, 3.9.0 ≤ v < 3.9.8, 3.10.0 ≤ v < 3.10.5, 3.11.0 ≤ v < 3.11.3 | 3.8.13, 3.9.8, 3.10.5, 3.11.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.