CVE-2024-0640
Medium
Description
A stored cross-site scripting (XSS) vulnerability exists in chatwoot/chatwoot versions 3.0.0 to 3.5.1. This vulnerability allows an admin user to inject malicious JavaScript code via the dashboard app settings, which can then be executed by another admin user when they access the affected dashboard app. The issue is fixed in version 3.5.2.
SeverityMedium
CVSS4.8
Exploit probability—
Product
Chatwoot
PublishedMar 20, 2025
First seenMar 20, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- chatwoot chatwoot3.5.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| chatwoot chatwoot | v < 3.5.2 | 3.5.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.