CVE-2024-10002

High

Description

The Rover IDX plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.0.0.2905. This is due to insufficient validation and capability check on the 'rover_idx_refresh_social_callback' function. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in to administrator. The vulnerability is partially patched in version 3.0.0.2905 and fully patched in version 3.0.0.2906.

SeverityHigh
CVSS8.8
Exploit probability—
ProductRoveridx Rover Idx
PublishedOct 22, 2024
First seenOct 22, 2024
Weakness typeCWE-288CWE-288

How to fix

Update
  • roveridx rover_idx3.0.0.2906 or later

Affected products

ProductAffected versionsFixed in
roveridx rover_idxv < 3.0.0.29063.0.0.2906

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-10002 · Roveridx Rover Idx · Dark Radar