CVE-2024-10326

Medium

Description

The RomethemeKit For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_options and reset_widgets functions in all versions up to, and including, 1.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify plugin settings or reset plugin widgets to their default state (all enabled). NOTE: This vulnerability was partially fixed in version 1.5.3.

SeverityMedium
CVSS4.3
Exploit probability—
ProductRomethemekit For Elementor
PublishedMar 8, 2025
First seenMar 8, 2025

How to fix

Update
  • rometheme romethemekit_for_elementor1.5.4 or later

Affected products

ProductAffected versionsFixed in
rometheme romethemekit_for_elementorv < 1.5.41.5.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.