CVE-2024-10720

Medium

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability occurs in the 'Device Management' section under 'Administration' where an attacker can inject malicious scripts into the 'Name' and 'Description' fields when adding a new device type. This can lead to data theft, account compromise, distribution of malware, website defacement, and phishing attacks. The issue is fixed in version 1.7.0.

SeverityMedium
CVSS6.1
Exploit probability—
ProductPhpipam
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • phpipam phpipam1.7.0 or later

Affected products

ProductAffected versionsFixed in
phpipam phpipamv < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-10720 · Phpipam · Dark Radar