CVE-2024-10722

Medium

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability allows attackers to inject malicious scripts into the 'Description' field of custom fields in the 'IP RELATED MANAGEMENT' section. This can lead to data theft, account compromise, distribution of malware, website defacement, content manipulation, and phishing attacks. The issue is fixed in version 1.7.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductPhpipam
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • phpipam phpipam1.7.0 or later

Affected products

ProductAffected versionsFixed in
phpipam phpipamv < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.