CVE-2024-10723

Medium

Description

A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the destination address field of the NAT tool, which can be executed when a user interacts with the field. The impact of this vulnerability includes the potential theft of user cookies, unauthorized access to user accounts, and redirection to malicious websites. The issue has been fixed in version 1.7.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductPhpipam
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • phpipam phpipam1.7.0 or later

Affected products

ProductAffected versionsFixed in
phpipam phpipamv < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.