CVE-2024-10725

Medium

Description

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the application, which are then executed in the context of other users who view the affected pages. The issue occurs when editing the NAT destination address, where user input is not properly sanitized. This can lead to data theft, account compromise, and other malicious activities. The vulnerability is fixed in version 1.7.0.

SeverityMedium
CVSS5.4
Exploit probability29. percentile0.3%
ProductPhpipam
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • phpipam phpipam1.7.0 or later

Affected products

ProductAffected versionsFixed in
phpipam phpipamv < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.