CVE-2024-10975
High
Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
SeverityHigh
CVSS7.7
Exploit probability—
ProductHashicorp Nomad
PublishedNov 7, 2024
First seenNov 7, 2024
Weakness typeCWE-863Incorrect authorization
How to fix
Update
- hashicorp nomad1.7.15, 1.9.2, 1.8.7 or later
- github.com/hashicorp/nomad1.9.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp nomad | 1.3.0 ≤ v < 1.7.15, 1.3.0 ≤ v < 1.9.2, 1.8.0 ≤ v < 1.8.7, 1.9.0 ≤ v < 1.9.2 | 1.7.15, 1.9.2, 1.8.7 |
| github.com/hashicorp/nomadGo | v ≤ 1.9.1, v < 1.9.2 | 1.9.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.