CVE-2024-12029

Critical

Description

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

SeverityCritical
CVSS9.8
Exploit probability—
ProductInvokeai
PublishedMar 20, 2025
First seenMar 20, 2025

How to fix

Update
  • invokeai5.4.3rc2, 5.4.3rc1 or later

Affected products

ProductAffected versionsFixed in
invokeaiPyPI5.3.1 ≤ v < 5.4.3rc2, 5.3.1 ≤ v < 5.4.3rc15.4.3rc2, 5.4.3rc1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.