CVE-2024-12087

Medium

Description

A path traversal vulnerability exists in rsync. It stems from behavior enabled by the `--inc-recursive` option, a default-enabled option for many client options and can be enabled by the server even if not explicitly enabled by the client. When using the `--inc-recursive` option, a lack of proper symlink verification coupled with deduplication checks occurring on a per-file-list basis could allow a server to write files outside of the client's intended destination directory. A malicious server could write malicious files to arbitrary locations named after valid directories/paths on the client.

SeverityMedium
CVSS6.5
Exploit probability—
ProductSamba Rsync
PublishedJan 14, 2025
First seenJan 14, 2025

How to fix

Affected products

ProductAffected versionsFixed in
samba rsyncv ≤ 3.3.0—
almalinux almalinux8.0, 9.0, 10.0—
archlinux arch_linuxNo range specified—
gentoo linuxNo range specified—
nixos nixosv < 24.1124.11
suse suse_linuxNo range specified—
tritondatacenter smartosv < 2025012320250123
redhat enterprise_linux8.0, 9.0—
redhat enterprise_linux_eus9.6—
redhat enterprise_linux_for_arm_648.0_aarch64, 9.0_aarch64—
redhat enterprise_linux_for_arm_64_eus9.6_aarch64—
redhat enterprise_linux_for_ibm_z_systems8.0_s390x, 9.0_s390x—
redhat enterprise_linux_for_ibm_z_systems_eus9.6_s390x—
redhat enterprise_linux_for_power_little_endian8.0_ppc64le, 9.0_ppc64le—
redhat enterprise_linux_for_power_little_endian_eus9.6_ppc64le—
redhat enterprise_linux_server_aus9.6—
redhat enterprise_linux_server_for_power_little_endian_update_services_for_sap_solutions9.6_ppc64le—
redhat enterprise_linux_update_services_for_sap_solutions9.6—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.