CVE-2024-12635

Medium

Description

The WP Docs plugin for WordPress is vulnerable to time-based SQL Injection via the 'dir_id' parameter in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The vulnerability was partially patched in version 2.2.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductAndroidbubble Wp Docs
PublishedDec 21, 2024
First seenDec 21, 2024
Weakness typeCWE-89SQL injection

How to fix

Update
  • androidbubble wp_docs2.2.1 or later

Affected products

ProductAffected versionsFixed in
androidbubble wp_docsv < 2.2.12.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.