CVE-2024-12678

Medium

Description

Nomad Community and Nomad Enterprise ("Nomad") allocations are vulnerable to privilege escalation within a namespace through unredacted workload identity tokens. This vulnerability, identified as CVE-2024-12678, is fixed in Nomad Community Edition 1.9.4 and Nomad Enterprise 1.9.4, 1.8.8, and 1.7.16.

SeverityMedium
CVSS6.5
Exploit probability—
ProductHashicorp Nomad
PublishedDec 20, 2024
First seenDec 20, 2024
Weakness typeCWE-266CWE-266

How to fix

Update
  • hashicorp nomad1.7.16, 1.9.4, 1.8.8 or later
  • github.com/hashicorp/nomad1.9.4 or later

Affected products

ProductAffected versionsFixed in
hashicorp nomad1.4.0 ≤ v < 1.7.16, 1.4.0 ≤ v < 1.9.4, 1.8.0 ≤ v < 1.8.8, 1.9.0 ≤ v < 1.9.41.7.16, 1.9.4, 1.8.8
github.com/hashicorp/nomadGov < 1.9.41.9.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.