CVE-2024-12911
High
Description
A vulnerability in the `default_jsonalyzer` function of the `JSONalyzeQueryEngine` in the run-llama/llama_index repository allows for SQL injection via prompt injection. This can lead to arbitrary file creation and Denial-of-Service (DoS) attacks. The vulnerability affects the latest version and is fixed in version 0.5.1.
SeverityHigh
CVSS7.1
Exploit probability—
ProductLlamaindex
PublishedMar 20, 2025
First seenMar 20, 2025
Weakness typeCWE-89SQL injection
How to fix
Update
- llamaindex llamaindex0.5.1 or later
- llama-index0.12.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| llamaindex llamaindex | v < 0.5.1 | 0.5.1 |
| llama-indexPyPI | v < 0.12.3 | 0.12.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.