CVE-2024-12986
Description
A vulnerability, which was classified as critical, has been found in DrayTek Vigor2960 and Vigor300B 1.5.1.3/1.5.1.4. This issue affects some unknown processing of the file /cgi-bin/mainfunction.cgi/apmcfgupptim of the component Web Management Interface. The manipulation of the argument session leads to os command injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.5.1.5 is able to address this issue. It is recommended to upgrade the affected component.
How to fix
- draytek vigor300b_firmware1.5.1.5 or later
- draytek vigor2960_firmware1.5.1.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| draytek vigor300b_firmware | 1.5.1.3 ≤ v < 1.5.1.5 | 1.5.1.5 |
| draytek vigor2960_firmware | 1.5.1.3 ≤ v < 1.5.1.5 | 1.5.1.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.