CVE-2024-1329
High
Description
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
SeverityHigh
CVSS7.7
Exploit probability—
ProductHashicorp Nomad
PublishedFeb 8, 2024
First seenFeb 8, 2024
Weakness typeCWE-59Improper link resolution
How to fix
Update
- hashicorp nomad1.5.14, 1.6.7, 1.7.4 or later
- github.com/hashicorp/nomad1.5.14, 1.6.7, 1.7.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| hashicorp nomad | 1.5.13 ≤ v < 1.5.14, 1.6.6 ≤ v < 1.6.7, 1.7.3. ≤ v < 1.7.4 | 1.5.14, 1.6.7, 1.7.4 |
| github.com/hashicorp/nomadGo | 1.5.13 ≤ v < 1.5.14, 1.6.0 ≤ v < 1.6.7, 1.7.3 ≤ v < 1.7.4 | 1.5.14, 1.6.7, 1.7.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.