CVE-2024-13359

High

Description

The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the add_product_input_fields_to_order_item_meta() function in all versions up to, and including, 1.12.0. This may make it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that by default the plugin is only vulnerable to a double extension file upload attack, unless an administrators leaves the accepted file extensions field blank which can make .php file uploads possible. Please note 1.12.2 was mistakenly marked as patched while 1.12.1 was marked as vulnerable for a short period of time, this is not the case and 1.12.1 is fully patched.

SeverityHigh
CVSS8.1
Exploit probability—
ProductTychesoftwares Product Input Fields For Woocommerce
PublishedMar 8, 2025
First seenMar 8, 2025

How to fix

Update
  • tychesoftwares product_input_fields_for_woocommerce1.12.2 or later

Affected products

ProductAffected versionsFixed in
tychesoftwares product_input_fields_for_woocommercev < 1.12.21.12.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-13359 · Tychesoftwares Product Input Fields For Woocommerce · Dark Radar