CVE-2024-13509

High

Description

The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.

SeverityHigh
CVSS7.2
Exploit probability—
ProductWestguardsolutions Ws Form
PublishedJan 28, 2025
First seenJan 28, 2025

How to fix

Update
  • westguardsolutions ws_form1.10.14 or later

Affected products

ProductAffected versionsFixed in
westguardsolutions ws_formv < 1.10.141.10.14

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.