CVE-2024-1538

High

Description

The File Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 7.2.4. This is due to missing or incorrect nonce validation on the wp_file_manager page that includes files through the 'lang' parameter. This makes it possible for unauthenticated attackers to include local JavaScript files that can be leveraged to achieve RCE via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This issue was partially patched in version 7.2.4, and fully patched in 7.2.5.

SeverityHigh
CVSS8.8
Exploit probability96. percentile10.7%
ProductFilemanagerpro File Manager
PublishedMar 21, 2024
First seenMar 21, 2024

How to fix

Update
  • filemanagerpro file_manager7.2.5 or later

Affected products

ProductAffected versionsFixed in
filemanagerpro file_managerv < 7.2.57.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.