CVE-2024-1735

Critical

Description

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

SeverityCritical
CVSS9.1
Exploit probability—
ProductLinecorp Armeria
PublishedFeb 26, 2024
First seenFeb 26, 2024

How to fix

Update
  • linecorp armeria1.27.2 or later
  • com.linecorp.armeria:armeria-saml1.27.2 or later

Affected products

ProductAffected versionsFixed in
linecorp armeriav < 1.27.21.27.2
com.linecorp.armeria:armeria-samlMavenv < 1.27.21.27.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-1735 · Linecorp Armeria · Dark Radar