CVE-2024-1852

High

Description

The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.4.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page which is the edit users page. This vulnerability was partially patched in version 3.4.9.2, and was fully patched in 3.4.9.3.

SeverityHigh
CVSS7.2
Exploit probability—
ProductButlerblog Wp-members
PublishedApr 9, 2024
First seenApr 9, 2024

How to fix

Update
  • butlerblog wp-members3.4.9.3 or later

Affected products

ProductAffected versionsFixed in
butlerblog wp-membersv < 3.4.9.33.4.9.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.