CVE-2024-1908
Description
An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use the Enterprise Actions GitHub Connect download token to fetch private repository data. An attacker would require an account on the server instance with non-default settings for GitHub Connect. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in versions 3.8.16, 3.9.11, 3.10.8, and 3.11.6. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.8.16, 3.9.11, 3.10.8, 3.11.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.8.16, 3.9.0 ≤ v < 3.9.11, 3.10.0 ≤ v < 3.10.8, 3.11.0 ≤ v < 3.11.6 | 3.8.16, 3.9.11, 3.10.8, 3.11.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.