CVE-2024-2035

Medium

Description

An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.

SeverityMedium
CVSS6.5
Exploit probability—
ProductZenml
PublishedJun 6, 2024
First seenJun 6, 2024

How to fix

Update
  • zenml zenml0.56.2 or later
  • zenml0.56.2 or later

Affected products

ProductAffected versionsFixed in
zenml zenmlv < 0.56.20.56.2
zenmlPyPIv < 0.56.20.56.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.