CVE-2024-21622
Medium
Description
Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Craftcms Craft Cms
PublishedJan 3, 2024
First seenJan 3, 2024
Weakness typeCWE-269Improper privilege management
How to fix
Update
- craftcms craft_cms3.9.6 or later
- craftcms/cms4.5.11, 3.9.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 3.0.0 ≤ v < 3.9.6, 4.0.0 ≤ v ≤ 4.5.15 | 3.9.6 |
| craftcms/cmsPackagist | 4.0.0-RC1 ≤ v < 4.5.11, 3.0.0 ≤ v < 3.9.6 | 4.5.11, 3.9.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.