CVE-2024-21642

High

Description

D-Tale is a visualizer for Pandas data structures. Users hosting versions D-Tale prior to 3.9.0 publicly can be vulnerable to server-side request forgery (SSRF), allowing attackers to access files on the server. Users should upgrade to version 3.9.0, where the `Load From the Web` input is turned off by default. The only workaround for versions earlier than 3.9.0 is to only host D-Tale to trusted users.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMan D-tale
PublishedJan 5, 2024
First seenJan 5, 2024

How to fix

Update
  • man d-tale3.9.0 or later
  • dtale3.9.0 or later

Affected products

ProductAffected versionsFixed in
man d-talev < 3.9.03.9.0
dtalePyPIv < 3.9.03.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.