CVE-2024-21647
Description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
How to fix
- puma puma5.6.8, 6.4.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| puma puma | v < 5.6.8, 6.0.0 ≤ v < 6.4.2 | 5.6.8, 6.4.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.