CVE-2024-21673
Description
This High severity Remote Code Execution (RCE) vulnerability was introduced in versions 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.0 and a CVSS Vector of CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H allows an authenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, high impact to integrity, high impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).
How to fix
- atlassian confluence_data_center7.19.18, 8.5.5, 8.7.2 or later
- atlassian confluence_server7.19.18, 8.5.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| atlassian confluence_data_center | 7.19.0 ≤ v < 7.19.18, 8.5.0 ≤ v < 8.5.5, 8.7.0 ≤ v < 8.7.2 | 7.19.18, 8.5.5, 8.7.2 |
| atlassian confluence_server | 7.19 ≤ v < 7.19.18, 8.5.0 ≤ v < 8.5.5, 8.7.0 ≤ v ≤ 8.7.2 | 7.19.18, 8.5.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.