CVE-2024-21677

High

Description

This High severity Path Traversal vulnerability was introduced in version 6.13.0 of Confluence Data Center. This Path Traversal vulnerability, with a CVSS Score of 8.3, allows an unauthenticated attacker to exploit an undefinable vulnerability which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Data Center Atlassian recommends that Confluence Data Center customers upgrade to the latest version and that Confluence Server customers upgrade to the latest 8.5.x LTS version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions See the release notes https://confluence.atlassian.com/doc/confluence-release-notes-327.html You can download the latest version of Confluence Data Center and Server from the download center https://www.atlassian.com/software/confluence/download-archives. This vulnerability was reported via our Bug Bounty program.

SeverityHigh
CVSS8.8
Exploit probability—
ProductAtlassian Confluence Data Center
PublishedMar 19, 2024
First seenMar 19, 2024

How to fix

Update
  • atlassian confluence_data_center7.19.20, 8.5.7, 8.8.1 or later
  • atlassian confluence_server7.19.20, 8.5.7 or later

Affected products

ProductAffected versionsFixed in
atlassian confluence_data_center6.13.0 ≤ v < 7.19.20, 7.20.0 ≤ v < 8.5.7, 8.6.0 ≤ v < 8.8.17.19.20, 8.5.7, 8.8.1
atlassian confluence_server6.13.0 ≤ v < 7.19.20, 7.20.0 ≤ v < 8.5.77.19.20, 8.5.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.