CVE-2024-2171

Medium

Description

A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.

SeverityMedium
CVSS4.8
Exploit probability—
ProductZenml
PublishedJun 6, 2024
First seenJun 6, 2024

How to fix

Update
  • zenml zenml0.56.2 or later
  • zenml0.56.2 or later

Affected products

ProductAffected versionsFixed in
zenml zenmlv < 0.56.20.56.2
zenmlPyPIv < 0.56.20.56.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.