CVE-2024-22212
Description
Nextcloud Global Site Selector is a tool which allows you to run multiple small Nextcloud instances and redirect users to the right server. A problem in the password verification method allows an attacker to authenticate as another user. It is recommended that the Nextcloud Global Site Selector is upgraded to version 1.4.1, 2.1.2, 2.3.4 or 2.4.5. There are no known workarounds for this issue.
How to fix
- nextcloud global_site_selector1.4.1, 2.1.2, 2.3.4, 2.4.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud global_site_selector | 1.1.0 ≤ v < 1.4.1, 2.0.0 ≤ v < 2.1.2, 2.2.0 ≤ v < 2.3.4, 2.4.0 ≤ v < 2.4.5 | 1.4.1, 2.1.2, 2.3.4, 2.4.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.