CVE-2024-22369
Description
Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
How to fix
- apache camel3.21.4, 4.0.4, 4.4.0 or later
- org.apache.camel:camel-sql3.21.4, 3.22.1, 4.0.4, 4.4.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 3.0.0 ≤ v < 3.21.4, 4.0.0 ≤ v < 4.0.4, 4.1.0 ≤ v < 4.4.0, 3.22.0 | 3.21.4, 4.0.4, 4.4.0 |
| org.apache.camel:camel-sqlMaven | 3.0.0 ≤ v < 3.21.4, 3.22.0 ≤ v < 3.22.1, 4.0.0 ≤ v < 4.0.4, 4.1.0 ≤ v < 4.4.0 | 3.21.4, 3.22.1, 4.0.4, 4.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.