CVE-2024-22371
Description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
How to fix
- apache camel3.21.4, 4.0.4, 4.4.0 or later
- org.apache.camel:camel-core3.21.4, 3.22.1, 4.0.4, 4.4.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 3.0.0 ≤ v < 3.21.4, 4.0.0 ≤ v < 4.0.4, 4.1.0 ≤ v < 4.4.0, 3.22.0 | 3.21.4, 4.0.4, 4.4.0 |
| org.apache.camel:camel-coreMaven | 3.0.0 ≤ v < 3.21.4, 3.22.0 ≤ v < 3.22.1, 4.0.0 ≤ v < 4.0.4, 4.1.0 ≤ v < 4.4.0 | 3.21.4, 3.22.1, 4.0.4, 4.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.