CVE-2024-22415

High

Description

jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.

SeverityHigh
CVSS7.3
Exploit probability—
ProductJupyter Language Server Protocol Integration
PublishedJan 18, 2024
First seenJan 18, 2024

How to fix

Update
  • jupyter language_server_protocol_integration2.2.2 or later
  • jupyter-lsp2.2.2 or later

Affected products

ProductAffected versionsFixed in
jupyter language_server_protocol_integrationv < 2.2.22.2.2
jupyter-lspPyPIv < 2.2.22.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.