CVE-2024-22421
Description
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. Users of JupyterLab who click on a malicious link may get their `Authorization` and `XSRFToken` tokens exposed to a third party when running an older `jupyter-server` version. JupyterLab versions 4.1.0b2, 4.0.11, and 3.6.7 are patched. No workaround has been identified, however users should ensure to upgrade `jupyter-server` to version 2.7.2 or newer which includes a redirect vulnerability fix.
How to fix
- jupyter jupyterlab3.6.7, 4.0.11 or later
- jupyter notebook7.0.7 or later
- jupyterlab4.0.11, 3.6.7 or later
- notebook7.0.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jupyter jupyterlab | v < 3.6.7, 4.0.0 ≤ v < 4.0.11 | 3.6.7, 4.0.11 |
| jupyter notebook | 7.0.0 ≤ v < 7.0.7 | 7.0.7 |
| fedoraproject fedora | 39 | — |
| jupyterlabPyPI | 4.0.0 ≤ v < 4.0.11, v < 3.6.7 | 4.0.11, 3.6.7 |
| notebookPyPI | 7.0.0 ≤ v < 7.0.7 | 7.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.