CVE-2024-22423

High

Description

yt-dlp is a youtube-dl fork with additional features and fixes. The patch that addressed CVE-2023-40581 attempted to prevent RCE when using `--exec` with `%q` by replacing double quotes with two double quotes. However, this escaping is not sufficient, and still allows expansion of environment variables. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2024.04.09 fixes this issue by properly escaping `%`. It replaces them with `%%cd:~,%`, a variable that expands to nothing, leaving only the leading percent. It is recommended to upgrade yt-dlp to version 2024.04.09 as soon as possible. Also, always be careful when using `--exec`, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade, avoid using any output template expansion in `--exec` other than `{}` (filepath); if expansion in `--exec` is needed, verify the fields you are using do not contain `"`, `|` or `&`; and/or instead of using `--exec`, write the info json and load the fields from it instead.

SeverityHigh
CVSS8.3
Exploit probability—
ProductYt-dlp
PublishedApr 9, 2024
First seenApr 9, 2024

How to fix

Update
  • yt-dlp_project yt-dlp2024.04.09 or later
  • yt-dlp2024.04.09 or later

Affected products

ProductAffected versionsFixed in
yt-dlp_project yt-dlp2021.04.11 ≤ v < 2024.04.092024.04.09
yt-dlpPyPI2021.04.11 ≤ v < 2024.04.092024.04.09

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2024-22423 · Yt-dlp · Dark Radar